AnsweredAssumed Answered

i.MX287 Start Up / Reset Problem

Question asked by Joachim Reichart on Oct 10, 2018
Latest reply on Oct 15, 2018 by igorpadykov

Hello,

 

we designed a i.MX287 costom board. The first samples (25 pieces) workes fine. Now we did produce a larger amount of samples (125 Pieces). From these 125 approximately 5-10% have Problems to start up probably. We use the VBAT only configuration, with no 5V applied to the i.MX28. To automaticly start, we tied the PSWITCH Pin to VDD_XTAL. In the scope picture below, we used a voltage supervisory circuit (on VBAT) to hold the Reset down for min. 140ms. The behavouir stays the same if we remove the voltage supervisory circuit.

 

CH1: VDDIO_3V3

CH2: SPI3_CLK (Nor Flash for SPL Loader)

CH3:PSWITCH

CH4: Reset

 

In the scope picture you can observe the after the reset, the DC/DC Circuit starts, the VDDIO rises to approximately 3.1V. The i.MX starts to get the SPL Loader from the NOR Flash (on the Debug UART there is the output "HTLLC"). After that the voltage decreases to round about 2.9V and gets even deeper after 300ms. In this condition the i.MX28 stays till the voltage was shut down. 

 

If we observe the DC/DC Converter, we can see that after loading the data from the NOR Flash, the DC/DC takes a break, and starts again, but not with the right voltage:

CH1: VDDIO_3V3

CH2: SPI3_CLK (Nor Flash for SPL Loader)

CH3:DCDC_LP

CH4: Reset

 

A proper start (now without voltage supervisory circuit) ist displayed in the picture below:

 

CH1: VDDIO_3V3

CH2: SPI3_CLK (Nor Flash for SPL Loader)

CH3:PSWITCH

CH4: Reset (is the same voltage as VDDIO_3V3)

 

Here we can observe that the VDDIO_3V3 breaks down to 1.5V after loading the data from the NOR Flash. After that the Voltage rises to approximately 3.3V.

 

The "Start Up Problem" can also be observed if we put the reset a few times to GND while all other voltages are applied.

CH1: VDDIO_3V3

CH2: SPI3_CLK (Nor Flash for SPL Loader)

CH3:PSWITCH

CH4: Reset

Here you can observe the "Start up Problem" while holding the Reste down with all other voltage applied.

 

Did anyone have similar Problems? Can anyone from NXP help? Is is it possible to get a schematic review from NXP?

 

Thanks.

Outcomes