AnsweredAssumed Answered

murata wifi on imx6ul

Question asked by David Luberger on Oct 8, 2018
Latest reply on Jun 20, 2019 by Romit Chatterjee

I'm getting errors during bootup regarding the murata type 1ck device for bt/wifi combo.  The boot log is attached.  It appears that the kernel can "see" the device, and the/a relevant section of the boot log follows.


From everything I can tell, my hardware is configured correctly.  I've followed the eval board connections exactly, and have also tried hard-wiring the wifi 3v3 supply and the wlan_reg_on pins to remove any influence by kernel on gpio's.

I've tried this with a known working 1CK module, and I know this kernel works on the eval board (with proper device tree mod).  how can i debug the SI attach failure? What could cause an SDIO register driver timeout error?


I followed the murata guide and put the proper driver files in /lib/firmware/brcm and /etc/firmware (downloaded from a freescale image).


kernel log while mmc1 device (wifi) is loaded:

dhd_module_init in
wifi_plat_dev_drv_probe no GPIO for OOB in device tree.
wifi_plat_dev_drv_probe continue with non-OOB mode.
Power-up adapter 'DHD generic adapter'
wifi_platform_bus_enumerate device present 1    ** doesn't this mean the wifi module is communicating??
random: fast init done
mmc1: queuing unknown CIS tuple 0x80 (2 bytes)  ** Murata says these lines appear during normal operation
mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
mmc1: queuing unknown CIS tuple 0x80 (6 bytes)
mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
mmc1: queuing unknown CIS tuple 0x80 (6 bytes)
mmc1: new high speed SDIO card at address 0001  ** also an indicator of proper operation
dhdsdio_probe_attach: si_attach failed!  ** this occurs after several seconds; what happened??
dhdsdio_probe: dhdsdio_probe_attach failed
bcmsdh_sdmmc: probe of mmc1:0001:2 failed with error -12
dhd_wifi_platform_load_sdio: sdio_register_driver timeout or error
wifi_platform_bus_enumerate device present 0
mmc1: card 0001 removed