AnsweredAssumed Answered

imx8 gpu crash when playing video

Question asked by jiang yaqiang on Sep 28, 2018
Latest reply on Oct 1, 2018 by jiang yaqiang

HI  anyone:

 

I face a problem of gpu crash when playing video (the testing video is 1080p ,hdmi output).

 

platform: mx8mq , fsl-yocto-L4.9.51_mx8mq-ga (xwaylan).

 

the phenomenon happens about every one hour, at most time it had no log, just system hang up quietly .

 

 

here is part log(complete log in the attachment):

====== AIUR: 4.3.4 build on Aug 23 2018 15:19:16. ======
Core: MPEG4PARSER_06.13.06 build on Feb 6 2018 07:43:39
file: /usr/lib/imx-mm/parser/lib_mp4_parser_arm_elinux.so.3.2
------------------------
Track 00 [video_0] Enabled
Duration: 0:01:00.143411000
Language: eng
Mime:
video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)avc, width=(int)1920, height=(int)1080, framerate=(fraction)24000/1001, codec_data=(buffer)014d0033ffe10031674d4033965280f0044fcb80b4400000fa40002ee03840000f03c0001b775fc638c20000781e0000dbbafe31c3b430632c01000568e9093520
------------------------
====== VPUDEC: 4.3.4 build on Aug 23 2018 15:19:29. ======
wrapper: 3.0.0 (VPUWRAPPER_ARM64_LINUX Build on Aug 23 2018 14:27:18)
vpulib: 1.1.1
firmware: 1.1.1.65535
------------------------
Track 01 [audio_0] Enabled
Duration: 0:01:00.186122000
Language: eng
Mime:
audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)44100, bitrate=(int)61615, stream-format=(string)raw, codec_data=(buffer)12100000
------------------------
[12926.162132] function:imx_hifi_hw_params line:85 params_rate(params):44100
[12926.169197] sample_rate:44100 sample_format:2
[12926.175787] function:imx_hifi_hw_params line:120 priv->clk_frequency :24576000
[12926.183453] rt5640 0-001c: bclk is 1411200Hz and lrck is 44100Hz
[12926.189478] rt5640 0-001c: bclk_ms is 0 and pre_div is 1 for iis 0

====== BEEP: 4.3.4 build on Aug 23 2018 15:19:21. ======
Core: AAC decoder Wrapper build on Dec 7 2017 18:13:51
file: /usr/lib/imx-mm/audio-codec/wrap/lib_aacd_wrap_arm_elinux.so.3
CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.09.00_ARMV8 build on Sep 20 2017 15:02:50.
Redistribute latency...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "playbin0".
Execution ended after 0:00:55.297515425
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
Setting pipeline to PAUSED ...
[13009.799393] **************************
[13009.803159] *** GPU DRV CONFIG ***
[13009.807159] **************************
[13009.811072] Galcore version 6.2.4.150331
[13009.815103] Galcore options:
[13009.818113] irqLine = 49
[13009.821759] registerMemBase = 0x38000000
[13009.826102] registerMemSize = 0x00040000
[13009.830440] contiguousSize = 0x08000000
[13009.834781] contiguousBase = 0x00000000
[13009.839120] externalSize = 0x00000000
[13009.843463] externalBase = 0x00000000
[13009.847802] bankSize = 0x00000000
[13009.852143] fastClear = -1
[13009.855788] compression = 13
[13009.859434] signal = 48
[13009.863010] powerManagement = 1
[13009.866582] baseAddress = 0x40000000
[13009.871058] physSize = 0xC0000000
[13009.875419] logFileSize = 0 KB
[13009.879270] recovery = 0
[13009.882843] stuckDump = 0
[13009.886412] gpuProfiler = 0
[13009.889991] irqs = [13009.893289] -1,
-1, [13009.895561] -1,
-1, [13009.897763] -1,
-1, [13009.900032] -1,
-1, [13009.902233] -1,

Attachments

Outcomes