AnsweredAssumed Answered

root file system not properly installed?

Question asked by Atis Cace on Sep 24, 2018
Latest reply on Sep 24, 2018 by igorpadykov

Dear users,

I have encountered a problem for i.mx6DL board. I have a custom kernel, dtb and rootfs. When I use tftpboot, I can install everything, and everything works. However, I would like to do this over USB, not internet, so I tried using MFGtool2. MFGtool successfully uploads U-boot and custom files, however, when I boot, it just says loading kernel and stays there. I found it that if I erase.part rootfs, and put it back on via tftp it boots and everything works again. Therefore I suspect something wrong with the way MFGtool installs the rootfs. I looked in the batch file of MFGtool, but I did not find anything that could help me. I tried changing the compression from .bz2 to .tgz since it accepts several formats, but so far no luck. It just stays at 'booting kernel' and that is about it.  Has anyone encountered this, or has an idea how to approach this problem?

Best regards,

Atis

Outcomes