AnsweredAssumed Answered

Building QT5 image for imx6qpsabresd

Question asked by devika R on Sep 21, 2018
Latest reply on Sep 26, 2018 by gusarambula


Hello all,


We are building yocto project for IMX6 QUAD PLUS SABREDSD(imx6qpsabresd) machine by following the Freescale Yocto Project User's Guide.

However, we are facing problem in building the bitbake image for QT5 when we run the following command.
$ bitbake fsl-image-qt5-validation-imx

It says "qtbase_git.bb:do_compile" failed.
The same error is observed across two different versions of Yocto (L4.9.88_2.0.0 & L4.9.11_1.0.0)

The below mentioend DISTRO configuration is exported before the bitbake command.
$ DISTRO=fsl-imx-x11 MACHINE=imx6qpsabresd source fsl-setup-release.sh -b build-x11

After this error we've tried by clean building all but still facing the same issue.

Ubuntu version is 14.04 - 32-bit
Yocto version is L4.9.88_2.0.0

The error is as follows. I've attached the complete log file as well.

ERROR: Task (/home/developer/yocto_project/imx-yocto-bsp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1457 tasks of which 1455 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/home/developer/yocto_project/imx-yocto-bsp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile
Summary: There was 1 WARNING message shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Attachments

Outcomes