AnsweredAssumed Answered

S32 Design Studio : Launching project Default (61%) Stall

Question asked by Christopher Holland on Sep 20, 2018
Latest reply on Sep 25, 2018 by Mike Doidge

Hi,

 

For over a year, S32 Design Studio and PE Micro 'Multilink Universal' worked just fine.

Now, all of a sudden, S32 stalls at 61% for a very long time. Eventually it does reach 100%. Maybe after 5-10 minutes or so.

I don't know what could have happened. I moved the USB cables, but I moved them back.

I think there might have been a Windows Update. (I am using Windows 7) 

So now, I am trying to figure out the proper way to debug the issue.

 

It doesn't matter whether or not PE Micro 'Multilink Universal' is plugged in or not. It still sits at 61% for a long time.

1. I tried different hardware/projects, but that didn't make a difference.

2. I tried reinstalling PE Micro Drivers, but that didn't make a difference. 

3. I tried updating S32 Design Studio, but it's all up to date.

4. When I run pegdbserver stand-alone, it seems to startup up almost instantly.

 

Everything is working, it just takes a very long time.

 

I am going to keep mucking with it. I'll post results if and when I figure out what happened.

 

C:\NXP\S32DS_Power_v2017.R1\eclipse\plugins\com.pemicro.debug.gdbjtag.ppc_1.7.5.
201807182113\win32>pegdbserver_power_console.exe -startserver -device=MPC5746C

P&E GDB Server for Power devices, Version 6.94.00.00
Copyright 2018, P&E Microcomputer Systems Inc, All rights reserved

Loading library C:\NXP\S32DS_Power_v2017.R1\eclipse\plugins\com.pemicro.debug.gd
bjtag.ppc_1.7.5.201807182113\win32\gdi\unit_ngs_ppcnexus_internal.dll ... Done.

Command line arguments: -startserver -device=MPC5746C
Device selected is mpc5746c
HW Auto-Selected : Interface=USBMULTILINK Port=PEM16C71E ; USB1 : Multilink Un
iversal Rev C (PEM16C71E)
Connecting to target.
P&E Interface detected - Flash Version 9.81

Starting reset script (C:\NXP\S32DS_Power_v2017.R1\eclipse\plugins\com.pemicro.d
ebug.gdbjtag.ppc_1.7.5.201807182113\win32\gdi\P&E\s32e200_mpc574xc.mac) ...
REM This script is compatible with MPC574xC devices.


REM Clean GPRs to remove residual data after using algorithm


REM Initialize all of the Main SRAM - 512KB


Initializing RAM from $40000000 to $4007FFFF.

Reset script (C:\NXP\S32DS_Power_v2017.R1\eclipse\plugins\com.pemicro.debug.gdbj
tag.ppc_1.7.5.201807182113\win32\gdi\P&E\s32e200_mpc574xc.mac) completed.

MPC574xB/C/D Device detected.
Device is mpc5746c.
Mode is In-Circuit Debug.

(C)opyright 2012, P&E Microcomputer Systems, Inc. (www.pemicro.com)
API version is 101

Server 1 running on 127.0.0.1:7224
Server 2 running on 127.0.0.1:7226
Server 3 running on 127.0.0.1:7228
Server 4 running on 127.0.0.1:7230
Server 5 running on 127.0.0.1:7232
Server 6 running on 127.0.0.1:7234
Server 7 running on 127.0.0.1:7236
Server 8 running on 127.0.0.1:7238
Server 9 running on 127.0.0.1:7240
Server 10 running on 127.0.0.1:7242
All Servers Running

Outcomes