AnsweredAssumed Answered

How to disable FEC, replace with KPP?

Question asked by David Luberger on Sep 18, 2018
Latest reply on Sep 18, 2018 by David Luberger

I'm using the i.mx6ul processor. I think that maybe the fact that I'm using the FEC ports as the 8x8 kpp input is possibly causing a kernel hangup.  In the imx_v7_deconfig, there's no line for CONFIG_FEC for me to comment out. How do I disable FEC without causing build errors? If I try setting status="disabled" in the device tree, I get build errors.  Also, I don't see a way to setup pinmux to have the KPP use the FEC pads, which is where my keypad is connected.  I see the example setup for the keypad in the device tree, but that doesn't tell how to setup pin muxing or how to disable the FEC 1 and 2, even though the KPP uses the FEC pads.

Outcomes