AnsweredAssumed Answered

Need help: kernel seems to be hanging, but no way to tell

Question asked by David Luberger on Sep 18, 2018
Latest reply on Sep 19, 2018 by David Luberger

I'm stuck at the kernel message "Key type dns_resolver registered".  My SD card appears to be fine, bootloader is fine, I have an image on my LCD, there are no obvious error messages in my boot log (see attached).  I've used multiple file systems -- a minimal build with busybox, a version from buildroot, my own rootfs built with linaro, the demo version that comes with the eval board -- none of that helps. I've done everything I can think of in the the u-boot build and the kernel/device tree to make this all match my custom board; but the kernel always stops at this same point. I actually can't tell if it's hung or if it's actually doing something, but certainly there are no more messages coming out of the console. I've let it run for a few hours and nothing happens.

 

Can someone give me pointers on how to troubleshoot the kernel? Is there a way to verify whether the kernel has hung or is waiting on something or otherwise actively doing something? I don't know how to find where in the source code the kernel is no longer sending out info to the console, but some kind of progress indicator or note that says what it's waiting on would help.

 

Also, I've tried disabling most things in the device tree, and I've tried enabling most things. I'm at a complete loss as to what's going on.

Attachments

Outcomes