AnsweredAssumed Answered

How to enable UART2 in P2040

Question asked by gourav jain on Sep 18, 2018
Latest reply on Oct 1, 2018 by gourav jain

Hi All,

In my custom board which is based on P2041RDB, by default console prints are coming in UART1. But i wanted to get the output prints on UART2 instead UART1.  Following changes have been made from my end,

 

1) changed RCW[366:368] from 011 to 101

2) changed uboot parameter "consoldev" from ttyS0 to ttyS1.

but still prints are coming in UART1.

 

Note: As of now i'm trying at uboot level only. 

Can some one guide me what else change is required ??

 

Thanks,

Gourav

Outcomes