AnsweredAssumed Answered

P2040: Issue with MMC/SD card in kernel

Question asked by gourav jain on Sep 17, 2018
Latest reply on Oct 30, 2018 by Yiping Wang

Hi,

In my custom board, based on P2041rdb, SD/MMC card is throwing following error while linux is booting up,

 

mmc0: new high speed SDHC card at address b368
mmcblk0: mmc0:b368 SDC 7.34 GiB
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
mmcblk0:
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 0
mmcblk0: error -110 transferring data, sector 1, nr 7, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 1
EXT2-fs (ram0): warning: mounting unchecked fs, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem) on device 1:0.
devtmpfs: mounted
Freeing unused kernel memory: 284k freed
INIT: version 2.88 booting
mmcblk0: error -110 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 2
Starting udev
udevd[907]: starting version 182
mmcblk0: error -110 transferring data, sector 3, nr 5, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 3
mmcblk0: error -110 transferring data, sector 4, nr 4, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 4
mmcblk0: error -110 transferring data, sector 5, nr 3, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 5
Starting Bootlog daemon: bootlogd: cannot allocate pseudo tty: No such file or directory
bootlogd.
mmcblk0: error -110 transferring data, sector 6, nr 2, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 6
mmcblk0: error -110 transferring data, sector 7, nr 1, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 7
Buffer I/O error on device mmcblk0, logical block 0
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
mmcblk0: retrying using single block read
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 0
mmcblk0: error -110 transferring data, sector 1, nr 7, cmd response 0x900, card status 0x0
end_request: I/O error, dev mmcblk0, sector 1
mmcblk0: error -110 transferring data, sector 2, nr 6, cmd response 0x900, card status 0x0
mmcblk0: error -110 transferring data, sector 3, nr 5, cmd response 0x900, card status 0x0
mmcblk0: error -110 transferring data, sector 4, nr 4, cmd response 0x900, card status 0x0
mmcblk0: error -110 transferring data, sector 5, nr 3, cmd response 0x900, card status 0x0
mmcblk0: error -110 transferring data, sector 6, nr 2, cmd response 0x900, card status 0x0
mmcblk0: error -110 transferring data, sector 7, nr 1, cmd response 0x900, card status 0x0
Buffer I/O error on device mmcblk0, logical block 0
EXT2-fs (mtdblock7): error: can't find an ext2 filesystem on dev mtdblock7.
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0
mmcblk0: retrying using single block read
mmcblk0: error -110 transferring data, sector 0, nr 8, cmd response 0x900, card status 0x0

 

 

Don't know from where to start debugging this error. Can anyone throw some light on my issue.

Thanks,

Gourav

Outcomes