AnsweredAssumed Answered

PREFERRED_PROVIDER_virtual/kernel not works as expected

Question asked by 计龙 杨 on Sep 7, 2018
Latest reply on Sep 28, 2018 by gusarambula

I'm building the latest source on https://source.codeaurora.org/external/imx/imx-manifest for imx6q:

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-rocko -m imx-4.9.88-2.0.0_ga.xml

DISTRO=fsl-imx-fb MACHINE=imx6qsabreauto source fsl-setup-release.sh -b build-fb

But failed on switching kernel to linux-fslc_4.9 or 4.14, defined in 

imx-yocto-bsp/sources/meta-freescale/recipes-kernel/linux/linux-fslc_4.9.bb

imx-yocto-bsp/sources/meta-freescale/recipes-kernel/linux/linux-fslc_4.14.bb

 

Reproduce steps:

1. bitbake virtual/kernel && bitbake virtual/kernel -e | grep ^T=

    output:

        T="/home/XXX/imx-yocto-bsp/build-fb/tmp/work/imx6qsabreauto-poky-linux-gnueabi/linux-imx/4.9.88-r0/temp"

2. Add two lines to conf/local.conf:

       PREFERRED_PROVIDER_virtual/kernel = "linux-fslc"
       PREFERRED_VERSION_linux-fslc = "4.14"

3. bitbake virtual/kernel -c cleansstate

4. Check again: bitbake virtual/kernel -e | grep ^T=

        The output as same as in step 1, not switched to linux-fslc

 

Even if execute bitbake virtual/kernel without other parameters, linux-fslc still not built but linux-imx instead.

 

I tried yocto's official poky 2.5.1 as above steps, it switched kernel from linux-yocto_4.14.48 to linux-yocto-rt_4.15.18 successfully.

Outcomes