AnsweredAssumed Answered

My ticket

Question asked by Anwar Hussain on Aug 20, 2018

Not able to trigger GPT interrupt:

MCAL: S32K148

MCAL Ver: T40D2M10I0R0

 

We are facing issue with the GPT, as the Interrupts are not getting triggered on Timer overflow. Below are the brief updates of what has been tried.

1.   We configured FTM0 (Ch0), used SYS CLK (80MHz) as clock source, and FTM_0_CH_0_CH_1_ISR as ISR.

We could see the counter running, TOF being set. But the Interrupt is not getting triggered.

Looking into the NXP drivers in the Gpt_Ipw_EnableInterrupt(), the Interrupts are not enabled for FTM.

 

2.   We also tried with using LPIT0. With the configurations done, we could see the relevant bits set accordingly in debugger for registers MSR, MIER, TCTRL.

Since, the ISR for LPIT0 (Gpt_LPIT_0_TIMER_0_ISR) is not available in the NXP driver, tried to have our own ISR. But we could not see the Interrupt getting triggered.

 

Config files are attached

Attachments

Outcomes