AnsweredAssumed Answered

iMX6Q Sudden Freeze with EXAR Linux USB Serial Driver

Question asked by Viswanathan Muthuramakrishnan on Aug 9, 2018
Latest reply on Aug 22, 2018 by Viswanathan Muthuramakrishnan

Hi,

 

We are using linux 3.14.61 imx6 BSP and also tried with linux 4.9.88 BSP for testing the USB-Serial controller.

We are using the EXAR USB serial controller and testing with the USB-Serial test application  (writing the data continuously). We are checking through the serial port console from the host PC. But after sometime i.e 20 minutes the system is not responding and it looks frezzed.There is no kernel panic observed or no error messages in console. 

 

we tried to alloc buffers in EXAR driver with GFP_DMA | GFP_ATOMIC flag @(instead of existing GFP_KERNEL) we could see some improvements i.e hang failure happens later than 40 minutes. The issue observed in both SMP and NO SMP cases.

We have added few kernel options for debugging, but we are not getting any logs during the time of hang.

We have enabled ftrace in the kernel and captured logs.

 

Please find the attached ftrace log files which we have tested with 3.14.61 linux kernel and 4.9.88 linux kernel.

 

1. Could you please confirm if there is any issues similar to this?

2. Please confirm if there is any bug fix/ ERRATA available?

3. Is there any imx6 firmware update available?

4. Any debugging option available in imx6  kernel.

 

IMX6 Part Num: MCIMX6Q7CVT08AC

QCN1633

msia fgcnqy

 

Regards

Viswanathan M

 

 

Attachments

Outcomes