AnsweredAssumed Answered

eGalax Touchscreen control via USB on IMX6QP

Question asked by Chetan Kumar Sanga on Jul 26, 2018
Latest reply on Aug 1, 2018 by Chetan Kumar Sanga

Hi all,

 

I'm a newbie to this work.

 

I'm trying to bring up eGalax Touchscreen on an existing custom HW based on IMX6QP using imx-o8.0.0_1.0.0_ga/ AOSP. This hardware was using another software different than Android and the touch works fine with that software. I've customised AOSP to bring up android on this target, with SabreSDB as reference.

 

This device is interfaced to the SOC via the USBOTG pins. The USBOTG supply is directly available without control pin and the P/N pins are connected properly. I've done the configurations to select the relevant drivers and verified the DTS.

 

When I run the Android, I observe the logs displaying the USB vendor/product IDs (0eef:c000). Device's detected as HID. And some input devices are being created for eGalax Touchscreen.

 

The driver required, as per my understanding, is hid-multitouch.

 

My changes:

1. Updated the configuration file to build HID and Touchscreen drivers for eGalax.

2. Added a touch-enable code - GPIO which is made to act as touch-enabler is set to high.

3. Modified the code on usbtouchscreen.c by adding the above IDs in the id-table and tried the same in hid-multitouch.c in separate runs.

4. Added log prints at various stages of probe, interrupt handling and input-event reader API of eGalax. 

 

In any case, touch events are not being reported.

 

Display is still not up. Touchscreen shouldn't be dependent on Display. Right or wrong?

 

Please help. Will update if further details are required or if I get lucky.

Outcomes