AnsweredAssumed Answered

S32K142: Can't connect JTAG

Question asked by Sri Harsha Pavuluri on Jul 25, 2018
Latest reply on Jul 30, 2018 by Sri Harsha Pavuluri

Hello,

 

I am trying to connect the S32K142 CPU on my custom board to program it. I am using the U-Multilink debugger. The amber light and the blue light on the debugger are turned on when I connect but if I try to debug, I get this error:

I tried with lower communication speed and with delay after reset and it still doesn't work. I probed the rest pin and there is pulse every few microseconds. I understand that this is normal behavior for new chips, but this behavior continue if I try to erase flash also (I don't get a notification to erase flash, but I can't manually erase it by running the flash partitioning example). This is how the JTAG port is connected to the MCU on my board:

 

I initially thought it was because the reset pin wasn't pulled up to 3.3v so I connected a 10k pullup. It still doesn't work, for some reason.

 

Please help!

Outcomes