AnsweredAssumed Answered

Yocto Rocko QT5 SDK failure

Question asked by Alric Fitterer on Jul 21, 2018
Latest reply on Oct 21, 2018 by shaojun ke

Hi all,

If this is not the correct place to post, please let me know.

I'm trying to do a Yocto build with the following. Below are the errors for both distro fslc-x11 and poky.

Any thoughts on how to fix this?

MACHINE=imx6qdlsabresd

DISTRO=fslc-x11 (also tried poky)

inherit populate_sdk_qt5

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-rocko -m imx-4.9.88-2.0.0_ga.xml

build machine ubuntu-16.04

 

Error: Transaction check error:
  file /opt/fslc-x11/2.4.2/sysroots/x86_64-fslcsdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.8.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.9.6+git0+9c50112304-r0.x86_64_nativesdk

 

I've also tried DISTRO=poky, this fails for qtwayland_git.bb

| ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-client && features.opengl && !features.opengles2 && features.xlib && libs.xcomposite && libs.glx' failed.
|
| ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-server && features.opengl && !features.opengles2 && libs.xcomposite && libs.glx' failed.

 

Alric

Outcomes