AnsweredAssumed Answered

i.MX7ULP_EVB USB OTG enable problem

Question asked by Sam Liu on Jul 20, 2018
Latest reply on Jul 27, 2018 by Yuri Muhin

Hi Everyone,

  I have some questions about how should I do that can correctly enable USB OTG on i.MX7ULP_EVB. 

  (BSP version : imx-4.9.51-8mq_ga.).

 

  My purpose is :

  Setting i.mx7ulp_evb as a "USB device" , and connect the Type-C USB port(It's is locate on i.mx7ulp_evb )  into my PC , let my PC can recognize i.mx7ulp_EVB as a USB device (eg. A mass storage)

 

 

But now my PC can't recognize  the i.mx7ulp_evb as a USB device.

  And I already according to "i.MX Reference Manual ,Document Number: IMXLXRM ,Rev. L4.9.51_imx8mq-beta, 01/2018" to setting parameters (These parameters almost default :y in BSP) :

 

 ============================================================

1. CONFIG_USB-Build Support for Host-side USB
2. CONFIG_USB_EHCI_HCD EHCI HCD (USB 2.0) support
Default y
3. CONFIG_USB_CHIPIDEA- ChipIdea high-speed Dual Role Controller
Default y
4. CONFIG_USB_CHIPIDEA_UDC - ChipIdea device controller
Default y
5. CONFIG_USB_CHIPIDEA_HOST - ChipIdea host controller
Default y
6. CONFIG_USB_GADGET - USB Gadget Support
Default y
7. CONFIG_USB_MXS_PHY - Freescale MXS USB PHY support
Default y

=============================================================

 

My question show as below:

1. The parameter : "OTG support " in menuconfig:

    ---Device drivers 

       ---USB support 

           [ ] OTG support  <-------   Does this parameter should set to "y" ?

 

2.In the original  "i.mx7ulp_evk.dts" in "imx-4.9.51-8mq_ga BSP" , the  CC Logic Control : PTN5150A(it's for type-c driver ) is not setting .

   Should I need to add device node PTN5150A  manually or not?

 

3.Why I can't find  the 

"/sys/bus/usb/devices/usb1"

and 

"/sys/bus/usb/devices/1-1"  in i.mx7ulp linux kernel environment.

 

4.In original "&usbotg1" node in "i.mx7ulp_evk.dts" as below :

------------------------------------------------------

&usbotg1 {
vbus-supply = <&reg_usb_otg1_vbus>;
extcon = <0>, <&extcon_usb1>;
srp-disable;
hnp-disable;
adp-disable;
status = "okay";
}; 

----------------------------------------------------

It's neither set 

dr_mode = "host"

nor 

dr_mode ="peripheral"

nor

dr_mode = "otg" 

    Should I need to add "dr_mode = "otg"   into or not?

 

 

5.In the menuconfig ,whether any parameters of my setting is incorrect?

 

6.What steps should I do that  can enable USB otg correctly?

 

Thanks.   

Outcomes