AnsweredAssumed Answered

TRK-MPC5606B flash programming with RAppId BL fails

Question asked by dai feidi on Jul 10, 2018
Latest reply on Jul 19, 2018 by dai feidi

Hello guys,

I tried to flash the evaluation board TRK-MPC5606B as described with the RAppId Boot Loader Utility, but for some reason it doesn't work.

External power 12VDC, Jumper settings (SBC_5V, J17 1-2, J18 2-3, J7 1-2, J8 1-2) as described in the corresponding training manual. And here are my configure settings.




At first there's always a messagebox tells "Loss Communication with BAM. Check Password or Verify Boot Configuration Setting ABS2=1, ABS1=0, FAB=1. Please cycle power and try again."
Then I kept pull out and insert the USB line again and again.One out of five times,it moves on to the next step. (progress indication increases "BTL 0% to BTL 100 %" then "Init") but then I get the following error message "Loss Communication with CCP MCU. Please cycle power and try again."

I get the results when I attempt to flash the delivered example files "Training_LED_Example.mot".
I have also tried some advices from the community,but none of them works .

How to get .mot file to install RAppID BL Tool

TRK-MPC5606B flash programming with RAppId Boot Loader Utility fails

BAM problem: RAppID boot loader error (MPC 5644a)

 

I have enabled the tracing function,here is some of the data.

You may check the attachments if you would like to read all of them.

 

Have you guys ever met the same problem,that every time tried to program the chip you have to pull out and insert the USB line again?

How can I get over the "Loss Communication " problem and move on to the next step?

Any help appreciated.

Thank you.

Outcomes