AnsweredAssumed Answered

DAPLINK FIRMWARE UPDATION ON EVKB

Question asked by Anjalik Krishna on Jul 9, 2018
Latest reply on Jul 10, 2018 by ZhangJennie

Hi , 

   I tried to update the DAPLINK FIRMWARE of the EVKB board by following the  steps as given in the attached document.

I was trying to update the EVKB board with the on-board QSPI support firmware . But even after hardware changes QSPI was not working. So I planned to revert the old state of the board by flashing the default firmware which I got from the same site . OpenSDA Serial and Debug Adapter|NXP 

 I connected the board to my PC through opensda and tried to debug using MCUXpresso. But "Wire ACK Wait on DAP Access " error  is occuring. Usually I ll go for a Hyperflash erase when this error occurs . But when I try to erase the following error appears

 

Executing flash operation 'Erase' (Erase flash) - Tue Jul 10 10:41:18 IST 2018
Checking MCU info...
Scanning for targets...
Executing flash action...
MCUXpresso IDE RedlinkMulti Driver v10.2 (May 10 2018 18:10:59 - crt_emu_cm_redlink.exe build 510)
( 0) Reading remote configuration
Wc(03). No cache support.
Found chip XML file in C:/Users/shwetha/Documents/MCUXpressoIDE_10.2.0_759/workspace/erase_hello_world/Debug\MIMXRT1052xxxxB.xml
( 5) Remote configuration complete
Reconnected to existing link server
Connecting to probe 1 core 0:0 (using server started externally) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0227000041114e450044300ac207003792d1000097969900
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&2ffdb216&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0:0 after searching for a good core
connection failed - Nn(05). Wire ACK Wait in DAP access.. Retrying
Using memory from core 0:0 after searching for a good core
Failed on connect: Nn(05). Wire ACK Wait in DAP access
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Last stub error 0: OK

Outcomes