AnsweredAssumed Answered

Can't read from serial port on Sabre IMX7 dual

Question asked by Alexander Leccese on Jul 2, 2018
Latest reply on Jul 11, 2018 by ANKIT PATEL

I have an RS-232 cable plugged into my IMX7 board. The RS-232 has data coming from an external source to the board. I know data is flowing because I can read this data on a windows computer as soon as I plug it in. 

 

I am trying to simply read this data on my IMX7 board (which has the default Linux OS on it) and print it to the command line screen. I have tried doing cat ttymxc4 but nothing happens. I have tried this for ttymxc0, ttymxc1, ..., ttymxc6 but nothing is being received. By default only ttymxc0, ttymxc4, and ttymxc5 were enabled. I had to edit the .dtb file to enable all seven serial ports (but I still do not get data from any of them). 

 

 

Is there something I am missing here? how do you "map" a ttymx device to that RS232 port on my board (labelled CAN19 or J19). 

 

Please help me read this data into the command line. Thanks.

Outcomes