AnsweredAssumed Answered

bad image sequence number ubi_error even after flash_eraseall

Question asked by Mihaita Ivascu on Jun 28, 2018
Latest reply on Jul 20, 2018 by gusarambula

Hi all,    

 

  I was able to update the NAND succesfully using MFGtools on my imx6l phytec board.

    But when I try to boot the image I got the following issues:

 

booting 'nand'
ubi0 error: scan_peb: bad image sequence number 459621934 in PEB 832, expected 706885778
Erase counter header dump:
        magic          0x55424923
        version        1
        ec             1
        vid_hdr_offset 2048
        data_offset    4096
        image_seq      459621934
        hdr_crc        0x49c942ea
erase counter header hexdump:
00000000: 23494255 00000001 00000000 01000000                UBI#............
00000010: 00080000 00100000 2e46651b 00000000                .........eF.....
00000020: 00000000 00000000 00000000 00000000                ................
00000030: 00000000 00000000 00000000 ea42c949                ............I.B.
ubi0 error: ubi_attach_mtd_dev: failed to attach mtd0, error -22
failed to attach: Invalid argument
could not open /dev/nand0.root.ubi.kernel: No such file or directory
Booting 'nand' failed: No such file or directory
booting 'nand' failed: No such file or directory
 What could be wrong?
  I have modified ucl2.xml script so it does flash_eraseall on all mtd partitions. The error persists. What should I investigate next? Is there an alternative to ubifs? Should I check for specific ubifs features in my barebox image?    
Thanks,
      Mihaita
  
  

Outcomes