AnsweredAssumed Answered

LS1021A TWR Core not responding

Question asked by Charles Yocum on Jun 20, 2018
Latest reply on Oct 25, 2018 by Charles Yocum

I am attempting to run the demo bareboard project on an LS1021A TWR. I am using the Codewarrior TAP over Ethernet. It gets to Connecting... (82%), hangs for a while, and then fails with the error:

Error launching LS1021A-Bareboard-core0_RAM_LS1021ATWR_Download
CCSProtocolPlugin : Failed to correctly configure the JTAG chain

After it failed in Codewarrior, I attempted to use `ccs` to figure out why:

Server listening on port: 41475
Clients allowed from all hosts
No clients denied
(bin) 49 % config cc cwtap:192.168.1.111
(bin) 50 % show cc
0: CodeWarrior TAP (cwtap:192.168.1.111) CC software ver. {0.0}
(bin) 51 % ccs::config_chain {ls1020a dap sap2}
LS1020A: Core not responding

I previously had the project working with CMSIS-DAP, so I switched back to that (and adjusted S2:8 appropriately). I got a similar error:

Server listening on port: 41475
Clients allowed from all hosts
No clients denied
(bin) 49 % config cc cmsisdap
Identified CMSIS-DAP SERNUM: 2000020316845E10EB7881E8
Firmware version: 0203
0: CMSIS-DAP (cmsisdap) CC software ver. {0.3}
(bin) 50 % ccs::config_chain {ls1020a dap}
LS1020A: Core not responding
(bin) 51 %

Is it possible that there's something physically wrong with my board? Is there any way for me to get more information about what is going wrong with the JTAG chain? The board is booting in to U-Boot and TinyDistro just fine. I can also boot it off an SD Card that I've configured, but CodeWarrior and JTAG are not working.

Outcomes