AnsweredAssumed Answered

Hardware Flow Control (RS485) for KE18F

Question asked by Onur Demirel on Jun 18, 2018
Latest reply on Jun 26, 2018 by Kerry Zhou

Hello,

 

I am using TWR-KE18F board with elevator and TWR-IND-IO board. I want to use RS485 part of the IO card. I am using MOXA UPort 1250 to see the results in computer. 

 

All examples of LPUART has no hardware flow control. So I couldn't inspire from examples. In TWR-IND-IO card there is a ISO1176DW RS485 Transceiver. In this board the transceiver is connected in 'Reciever always on' configuration as default. For receiving nothing is needed; but for transmitting, Driver Enable pin is connected to RTS pin. 

 

First, I tried to set a GPIO pin High and connected to RTS pin of transceiver. I tried to send a string to that uart port and receive meaningless things. It is not all zeros or not all ones. But neither a shifted version or similar bits that I sent. 

 

Then I find MODIR register of this processor have internal RTS control. I couldn't find processor's reference manual, but I get help from this question and the answer given by xiangjun.rong. In default driver fsl_lpuart.c it only enables RxRTS but in this context I need TxRTS and I added some similar code to enable TxRTS. I also give power it and made proper pin multiplexing. 

I added nothing more then these and try to run example codes. I obtain only [00] for every send operation in terminal. 

 

Ps. KE18F has only UART0 and UART1 but TWR-IND-IO uses UART2 for RS485. Therefore I connected manually corresponding pins to UART1 to UART2 (Tx, Rx, RTS). 

 

I am stucked here and really appreciate any help.

 

Onur

Outcomes