AnsweredAssumed Answered

Ethernet error for k66

Question asked by matyb on Jun 8, 2018
Latest reply on Jun 13, 2018 by Daniel Chen

Good morning, I've been attempting to just initialize the ethernet module on a k66, and I think I did, however the ENET_ErrorIRQ fires up as soon as I set a bit to receive packages. I cannot figure out why I am getting this error.

 

The bit that I am setting is the ENET_RDAR, that's when it all goes downhill. As soon as I set this bit after initializing all of my descriptors and buffers, that's when the IRQ fires up.

 

I recently found that when the error IRQ fires up I get an address in the MPU_EAR1 register and some bits set in the MPU_EDR1 register. My buffers descriptor should be aligned, they start at address 0x1FFF00D0. The address error in the EAR1 register is 0x1FFF00D4, which confuses me it should have access to this address location. I tried moving the location around and still the same error. The second part, the bits set in EDR1 are 0x80000032, which to my knowledge I am not using any master-slave communication. This is all that I have on my board, I've initialized the clocks, GPIO, and Ethernet. There's nothing else being used at this moment. Can anyone give me any advice as to what may be causing this?

 

Thank you!

Outcomes