AnsweredAssumed Answered

MINISASTOCSI Linux L4.9.88_2.0.0

Question asked by Shawn Nageli on Jun 5, 2018
Latest reply on Jun 11, 2018 by Shawn Nageli

I have been working to get the CSI camera adapter working with L4.9.88_2.0.0 (stock image).  When going into u-boot it could not find fsl-imx8mq-evk-mipi-csi2.dtb.  It is not installed in the stock image.

 

I found in the Linux Binary Demo Images - i.MX 8MQuad EVK folder several .dtb files one if which included Image-fsl-imx8mq-evk-mipi-csi2.dtb.  I copied this to the same directly I found he default dtb file ( /run/media/mmcblk0p1 ).  Once this was installed I was able to set in u-boot to this dtb and ran fine into Linux.

 

However, when running the gstreamer command provided in the documentation it is unable to open the pipeline.  I get the following error:

WARNING: erroneous pipeline: no element "v412src"

 

Any feedback would be appreciated.  It is plugged into J1502 as instructed.

Outcomes