AnsweredAssumed Answered

How to start the imx_rpmsg_pingpong Module on imx7s custom board

Question asked by Erik Friedel on May 31, 2018
Latest reply on Jun 10, 2018 by igorpadykov

Hi

 

I was working with the imx7s on a custom board with 512MB Ram (MIGHT BE IMPORTEND) and would like to start the pingpong example from FreeRTOS.

On the M4 side there are no Problems. The only changes made so far, are to board.h, clock_freq.c, pin_mux.c to change the used uart. The hello_world example works fine so there are no problems.

 

While trying to get the pingpong running I encounter a few problems. After editing the devicetree (enable the rpmsg and changing the usable-memory to "memory { linux,usable-memory = <0x80000000 0x1ff00000>;" only) and changing the vring from 0xBFFF0000 --> 0x9FFF0000 I was quiet confident. First problem was that after "Starting Kernel...", the kernel didn't start. Solved it somehow and reached Linux. As told in the documentation I run "modprobe imx_rpmsg_pingpong". Nothing happens. Same with imx_rpmsg_tty.

Using "lsmod" both are shown but none of them are used by anyone.

 

Desperately switching to fsl-image-validation-imx6ul7d and tried to copy rootfs and image to my board. After a few tweaks I saw Linux but wasn't able to start imx_rpmsg_pingpong.

 

If anyone can help me here pls feel free to do so

 

Erik

Outcomes