AnsweredAssumed Answered

Generate and keep compiler intermediary files

Question asked by Richard Copeman on May 29, 2018
Latest reply on May 29, 2018 by LPCX presso support



I would like to be able to keep the compiler intermediary files (*.i). However, when I check the (Project->Properties->C/C++ Build -> Settings ->Tool Settings->Preprocessor->Preprocess only (-E) ) box and try to re-build the project I get a failure when the linker is invoked:


Building target: frdmk64f_coverage.axf
Invoking: MCU Linker
arm-none-eabi-gcc -nostdlib -Xlinker -Map="" -Xlinker --gc-sections -Xlinker -print-memory-usage -Xlinker --sort-section=alignment -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=hard -mthumb -T frdmk64f_coverage_hello_world_Debug.ld -o "frdmk64f_coverage.axf" ./utilities/fsl_assert.o ./utilities/fsl_debug_console.o ./utilities/fsl_io.o ./utilities/fsl_log.o ./utilities/fsl_str.o ./startup/startup_mk64f12.o ./source/main.o ./drivers/fsl_clock.o ./drivers/fsl_common.o ./drivers/fsl_ftfx_cache.o ./drivers/fsl_ftfx_controller.o ./drivers/fsl_ftfx_flash.o ./drivers/fsl_ftfx_flexnvm.o ./drivers/fsl_gpio.o ./drivers/fsl_smc.o ./drivers/fsl_uart.o ./board/src/board.o ./board/src/clock_config.o ./board/peripherals.o ./board/pin_mux.o ./CMSIS/system_MK64F12.o
./utilities/fsl_assert.o: file not recognized: File format not recognized
collect2.exe: error: ld returned 1 exit status
make: *** [frdmk64f_coverage.axf] Error 1


If I uncheck the box, then everything builds as normal.


Even with the failure, no .i files are generated.


How do I configure MCUXpresso to generate and keep these files for me?