AnsweredAssumed Answered

KV10 Self Secures Itself

Question asked by Abel Seguer Garro on May 29, 2018
Latest reply on May 30, 2018 by Hui_Ma

Hello to all,

 

I have been dealing with this problem for a week now, and I really don't know what else to search for or try...

 

I made a PCB to drive some WS2812B LEDs (not important here), and I bought 5 MCUs (reference MKV10Z32VLC7).

As I can't afford a proper debugger, I used the OpenSDA of my TWR-KE18F to program one of this MCUs soldered on an adaptation PCB:

MKV10Z32VLC7 soldered on an adaptation generic PCB

This allowed me to try some parts of the code and even to drive some of the LEDs.

 

The problem started when the final PCBs arrived and I soldered one (schematic attached):

MKV10Z32VLC7 soldered on the final PCB

I was unable to debug a single time in the new PCB. But the first "test PCB" (that has literally nothing apart from the MCU) I can debug and connect without a problem.

 

One clear signal of something going wrong was the (in this case) red LED of the TWR board, which indicates the reset signal, constantly light up when the MCU is connected and powered. Later, with an oscilloscope I could see what many people have described as the MCU continuously resetting probably due to the watchdog.

 

After many research online I found the LinkServer GUI Flash programmer and I could manage to "Resurrect locked Kinetis device", but that only worked once and no more.

I could debug that resurrected MCU for a couple times before powercycling the board a few times and then it was "locked" again. Forever.

 

I borrowed a P&E Multilink from work for the weekend, and I could see a pop-up message telling me that the "Device is secure. Erase to unsecure?". After clicking on the YES option, the P&E Connection Assistant window would appear, as if it could not connect to the MCU, and after pressing "Retry" it would pop-up the "Secure Erase" message again. And this repeated for lots of tries... without success

 

Having access to the Multilink, I even unsoldered and soldered a new KV10 in the populated PCB, and tried to debug with the Multilink from the beginning... but the "Secure Erase?" message poped-up again

 

Out of the 5 MCUs I bought, I burnt one due to a wrong footprint of the linear regulator, another one is soldered on the adaptation PCB (the ONLY one that is still working), and two more are on the final PCBs (one fully populated, the other with ONLY the MCU, both fail); and last one was replaced on one of the 2 final PCBs.

 

What is causing the devices to self-secure? Maybe some supply issues? Why isn't the adaptation PCB failing? Should I keep the Reset_b pin low until the supply is stable? Are the SWD and Reset_b signals THAT critical? Haven't they internal pull-up resistors?

 

I am quite desperate on how to proceed next, what to search or what to try...

 

Any help would be much appreciated!

 

Many thanks in advance!!!

 

Abel.

Attachments

Outcomes