AnsweredAssumed Answered

Connection drops with imx7 picopi wifi

Question asked by Matti Sillanpää on May 16, 2018
Latest reply on Jun 22, 2018 by Diego Adrian Cuevas

Hi.

 

 

I'm using the meta-avs-demos -yocto project from Codeaurora. I received meta-avs-picopi-wifi from NXP. I've used same bcmdhd drivers in separate form with separately compiled kernel for some time now. And they work pretty badly.

 

Main issue is the connection drops. In perfect 5GHz network reception the it drops the connection tens of times per day ans sometimes it tries several times before getting connection. Sometimes it might work OK for couple of days.

 

Interestingly I cannot get connection to some networks at all if I don't have time set correctly. Also the system complains about lack of random numbers. I've tried googling about this for some time now, however there doesn't seem to be fix.

 

root@imx7d-pico:~# iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"xxxxxx"
Mode:Managed Frequency:5.24 GHz Access Point: E0:3F:49:ED:D2:B4
Bit Rate=234 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=55/70 Signal level=-55 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:381 Invalid misc:1 Missed beacon:0

 

udhcpc (v1.24.1) started
Successfully initialized wpa_supplicant
_dhd_wlfc_mac_entry_update():1649, entry(32)
Sending discover...
Sending discover...
CFG80211-ERROR) wl_cfg80211_connect : Connecting withe0:3f:49:ed:d2:b4 channel (48) ssid "xxxx", len (8)

connect failed event=0 e->status 1 e->reason 0
CFG80211-ERROR) wl_bss_connect_done : Report connect result - connection failed
Sending discover...
CFG80211-ERROR) wl_cfg80211_connect : Connecting withff:ff:ff:ff:ff:ff channel (48) ssid "xxxx", len (8)

CFG80211-ERROR) wl_run_escan : Escan set error (-16)
CFG80211-ERROR) wl_run_escan : error (-16)
CFG80211-ERROR) __wl_cfg80211_scan : Scan err = (-16), busy?-16
CFG80211-ERROR) wl_cfg80211_scan : scan error (-16)
wl_bss_connect_done succeeded with e0:3f:49:ed:d2:b4
wl_bss_connect_done succeeded with e0:3f:49:ed:d2:b4

 

I'm using haveged to help with the lack of random numbers. However I still occasionally get complain about it.

 

Any ideas here? I've tried using wext and nl80211.

Outcomes