AnsweredAssumed Answered

U-boot problem with a mcf5485 processor

Question asked by Raúl Moreno Beltrán on Oct 29, 2008
Latest reply on Nov 5, 2008 by Raúl Moreno Beltrán
Hello everybody!
 
I am trying to port U-boot to my custom board which has a mcf5485 processor.
 
First of all I run the U-boot in an evaluation board (M5484Lite evb) and it worked perfectly. Then I tried to do it with my custom board (after modifying and adding the right files). The problem seems to be in the internal SRAM at the beginning of the code (start.S). I enabled some LEDS and after several tries, I found out I couldn't have access to the internal SRAM, in spite of having the same code to the evaluation board.
 
However, if I use an external sram, the u-boot goes (not completely, but at least till I know it should without doing changes).
Regarding the datasheet and the code, I have to configure the RAMBAR0 and RAMBAR1 of the internal SRAM. From this moment, I should have access, but if I try to write in the memory, it crashes (I can observe that because the leds).
 
Does anyone ported the U-boot for their custom boards?
Some help would be appreciated.
Thanks.

Outcomes