AnsweredAssumed Answered

K64F VLPS Current Problem

Question asked by PARK JAICHANG on Apr 12, 2018
Latest reply on Apr 18, 2018 by Hui_Ma

Hi I'm using the Hexiwear (K64F Family) and MCUXpresso IDE.

My Debugger is Hexiwear Docking Station.

 

I tried to VLPS mode from VLPR. But VLPS current is to High.(About 9 - 10mA measured a whole board)

 

First. I Copied and pasted Reference Code a.

Second. Fixed Clock Frequency(Used MCUXpresso Config Tool) and LLWU pin ( changed PTC6 to PTA4 ( LLWU_P3) )

Then, Debugging and measurement current value.

 

  • I attached Two zip file of My code.
  1. 1. Hexi_Project.zip : power_manager code
  2. 2. MK64FN1M0xxx12_Project : power_mode_switch code

 

  • Questions
  1. How to Fix this problem.? 
  2. I read AN4503 2.3.9 VLPS (page11) but How to set debugger disable in MCUXpresso IDE?

 

Thanks

Jeffrey.

 

  • Reference Code.
  1. 1. SDK_2.3.1_FRDM-K64F\boards\frdmk64f\demo_apps\power_manager
  2. 2. SDK_2.3.1_FRDM-K64F\boards\frdmk64f\demo_apps\power_mode_switch
  3. 3. AN4503 : Power management for Kinetis MCUs.
  4. 4. An4470 :Using Low Power modes on Kinetis Family

Outcomes