AnsweredAssumed Answered

Problems with uploading fsl-image-core to LS1046ardb

Question asked by Bradley Marquardt on Apr 9, 2018
Latest reply on Apr 17, 2018 by Pavel Chubakov

I am trying to run fsl-image-core on the LS1046ardb. I ran bitbake fsl-image-core with the QorIQ SDK 2.0-1703. I am having trouble loading it onto the board. I am not quite sure if I am using the right files or the right commands.

 

I can run these commands fine

 

tftp 82000000 rcw_1600_qspiboot.bin
sf probe 0:1; sf erase 0 +$filesize; sf write 82000000 0 0x100

tftp 82000000 u-boot-qspi-2016.09+fslgit-r0.bin
sf probe 0:1; sf erase 100000 +$filesize; sf write 82000000 100000 $filesize

tftp 82000000 fsl_fman_ucode_ls1046_r1.0_106_4_18.bin
sf probe 0:1; sf erase 300000 +$filesize; sf write 82000000 300000 $filesize

cpld reset altbank

 

The trouble comes when trying to load the FIT image. The two .itb files in the images folder are ppa.itb and ppa-ls1046ardb-20180408194441.itb

 

I tried to follow the instructions in QORIQ-SDK-2.0-IC-REV0 section 4.4.8.9.1 using the second itb file using these commands

 

setenv bootargs ‘root=/dev/ram0 earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200’
saveenv

tftp a0000000 ppa-ls1046ardb-20180408194441.itb
bootm a0000000

 

This gave me this error

 

## Loading kernel from FIT Image at a0000000 ...
Using 'config@1' configuration
Could not find subimage node
ERROR: can't get kernel image!

 

I then tried the same process again but loading the ppa.itb to 64500000 before running cpld reset altbank but it gave me the same results

 

I also tried using Image-ls1046ardb.bin, fsl-image-core-ls1046ardb.ext2.gz.u-boot, and Image-fsl-ls1046a-rdb.dtb with these commands instead of with the .itb

 

tftp a0000000 Image-ls1046ardb.bin
tftp b0000000 fsl-image-core-ls1046ardb.ext2.gz.u-boot
tftp c0000000 Image-fsl-ls1046a-rdb.dtb
bootm a0000000 b0000000 c0000000

 

which gave me this error

 

Wrong Image Format for bootm command
ERROR: can't get kernel image!

 

i also tried bootm 'a0000000 b0000000 c0000000' but that just brought up the help options for bootm

 

The last thing i tried was booti a0000000 b0000000 c0000000 which gave me this error

 

Bad Linux ARM64 Image magic!

 

What is the proper way to deploy fsl-image-core to the target board

Outcomes