AnsweredAssumed Answered

J-Link support unavailable

Question asked by Robert Poor on Mar 28, 2018
Latest reply on Mar 31, 2018 by Claire Manalo

I'm making the transition from KDS-2.x to MCUXpresso 10.1.1 and have run into a small snag.  

 

Short form:

When I try to debug my device, I get an alert:

... and I'm not sure what it wants in the way of a path to the J-Link server.

Details:

My Environment:

  • macOS High Sierra 10.3.3
  • MCUXpresso 10.1.1
  • Segger J-Link GBD Server V6.301
  • USB Connection to J-Link
  • SWD interface to KL27Z64 device

What I've Tried:

  • This setup worked fine in my KDS 2.x setup
  • I can communicate with the device using the SEGGER J-Flash Lite V6.30i app -- it recognizes the device, so I know the connection is good.
  • In MCUXpresso, I installed SDK 2.3.0 and built the canonical "Hello, World" app from the SDK examples.  It compiled without error.
  • In MCUXpresso, I created a new Debug Configuration under GDB Segger Interface Debugging
  • On the Main tab, I verified the Project and C/C++ Application fields.
  • On the Debugger Settings tab:
    • JLink Interface = USB
    • Device = MKL27Z64xxx4 (I had to set that manually)
    • Target Interface = SWD
    • Speed = Auto
    • GDB Server Startup and Port Selection = Auto
    • GDB / SWO / TELNET / Endianness / Disconnect Behavior = [2331, 2332, 2333, little, Run]
    • Power Target = False
    • Enable Semihosting = True

What Happened:

When it first prompted me for a path to the J-Link Server, I clicked on "No", whereupon it failed with the message "Error in final launch sequence: Cannot get Jtag device".

 

The next time it prompted me, I clicked "Yes" and supplied "/Applications/SEGGER/JLink_V630i/JLinkGDBServer.app" as the path.  Evidently it didn't like that either, since it immediately repeated the same dialog box.

 

So this time I provided "/Applications/SEGGER/JLink_V630i/JLinkGDBServerCLExe" as the path.  This caused the dialog box to disappear, but the build still failed with "Error in final launch sequence: Cannot get Jtag device".

In Summary

The interface to the J-Link "just worked" in the KDS environment, so I've come to take it for granted.  I'm sure I'm missing some key piece of information in making the transition to MCUXpresso.  (And what are the changes that Erich Styger has already blogged about this?  Probably 95%!    I guess I should go check...)

Outcomes