AnsweredAssumed Answered

How to increase default Yocto kernel memory

Question asked by IMX7 Newbie on Mar 27, 2018
Latest reply on Apr 3, 2018 by IMX7 Newbie

Hi,

I have connected PCIE interface of IMX7(ARM A7- Yocto-Linux) and KC705 FPGA EVAL board and both are set to Gen2, 1 Lane.

https://www.nxp.com/products/processors-and-microcontrollers/applications-processors/i.mx-applications-processors/i.mx-7-processors/i.mx-7dual-processors-heterogeneous-processing-with-dual-arm-cortex-a7-cores-and-cortex-m4-core:i.MX7D

 

https://www.xilinx.com/support/documentation/boards_and_kits/kc705/ug810_KC705_Eval_Bd.pdf

 

When BARs size is set to 64 Megabytes(our requirement) in FPGA, IMX7 doesn’t support with standard Xilinx pcie driver and end up with following error:

 

root@imx7d-phyboard-zeta-001:/lib/modules# insmod /lib/modules/xpcie.ko
Base hw val 0
Base hw len 0
BAR0 of 0K
BAR0 of 0M
xpcie: Init: Could not remap memory.
insmod: ERROR: could not insert module /lib/modules/xpcie.ko: Operation not
permitted
root@imx7d-phyboard-zeta-001:/lib/modules#
but when BARs size is set to 4 Megabytes in FPGA, then IMX7 works. Is it due to limitation of IMX7 kernel memory size? I think default IMX7 kernel memory has to be increased by some means.

 

but I don't know how to increase default kernel memory size in Yocto. Is there any way for this? or there is another issue?

 

Relevant files are in attachment.

 

P.S. same Xilinx pcie driver in PC(Centos/Ubuntu) works for any setting.

Attachments

Outcomes