AnsweredAssumed Answered

How to install external libraries for ppce6500-fsl-linux compiler

Question asked by Julen Cruchaga on Mar 21, 2018
Latest reply on Mar 21, 2018 by Pavel Chubakov

I'm trying to compile a program powerpc-fsl-linux-g++ compiler. This program needs to include libxml/libglibmm libraries. When I compile that program with a g++ compiler everything is correct, but when I try to compile it with my cross compiler powerpc-fsl-linux-g++ these error are displayed on my console:

 

Console output :

/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lxml++-2.6
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: skipping incompatible /usr/lib/x86_64-linux-gnu/libxml2.a when searching for -lxml2
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lxml2
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: skipping incompatible /usr/lib/x86_64-linux-gnu/libglibmm-2.4.a when searching for -lglibmm-2.4
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lglibmm-2.4
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: skipping incompatible /usr/lib/x86_64-linux-gnu/libgobject-2.0.a when searching for -lgobject-2.0
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lgobject-2.0
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: skipping incompatible /usr/lib/x86_64-linux-gnu/libsigc-2.0.a when searching for -lsigc-2.0
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lsigc-2.0
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: skipping incompatible /usr/lib/x86_64-linux-gnu/libglib-2.0.a when searching for -lglib-2.0
/opt/fsl-qoriq/2.0/sysroots/x86_64-fslsdk-linux/usr/libexec/powerpc-fsl-linux/gcc/powerpc-fsl-linux/4.9.2/real-ld: cannot find -lglib-2.0

 

¿How I can get/install such libraries, consistent with powerpc-fsl-linux-g++ compiler?

 

Thank you very much!!

Outcomes