AnsweredAssumed Answered

USBDM 4.12.1.210, FRDM-KL25Z, not detecting K60 or KE18F?

Question asked by John Adamson on Feb 28, 2018
Latest reply on Mar 1, 2018 by John Adamson

I've been using USBDM (4.12.1.130 ?) with a FRDM-KL25Z board to work on K60 projects successfully.

Now I'm trying to bring up a KE18F board.

The board and software that I was using didn't seem to detect the processor correctly (said it was an MK10DX and wouldn't program the part), so I upgraded to 4.12.1.210 and downloaded new firmware to the FRDM board using FRDM-KL25Z.sx.  Still no joy, and now it can't detect the chip.  Connected to the earlier K60 project, and the new software can't properly detect the K60 (it apparently thinks that processor is an MK20DX64M7).   Tried "OpenSDAv2_1_Power.bin" firmware (because the KL25Z.sx file seemed to match version 1, and I'm pretty sure I was using 2_1 before), but doesn't seem any better. 

 

The KE18F board is brand new, our design, so a layout problem is a definite possibility.

But then why doesn't the latest software work with the K60?  Is there a version that should work with the KE18F?  

 

4.12.1.130 firmware and ARM Flash Programmer (OpenSDAv2_1.bin, "USBDM ARM-SWD for OpenSDA2")

K60   detects chip

KE18F fails, "Reason: Target reset pin timeout (rise)" or "Failed to probe target"

There's a 10k pull-up to 3.3V, a reset module (same as K60) but - now - no cap to ground.

 

4.12.1.210 (KL25Z.sx firmware, "USBDM ARM-SWD for OpenSDAv1")

K60 says it's MK20DX64M7

KE18F says it's MK20DX64M7 (different result on a second attempt?)

 

4.12.1.210 (OpenSDAv2_1_Power.bin firmware, "USBDM ARM-SWD for OpenSDAv2.1")

K60  says it's MK20DX64M7

KE18F says it's MK20DX64M7 (different result this time?)

Outcomes