AnsweredAssumed Answered

IMX6 yocto fido meta-qt5 - cannot set EGLFS environment variables

Question asked by Arin Sara Mathew on Feb 25, 2018
Latest reply on Mar 1, 2018 by Arin Sara Mathew

Hi,

I am currently working on a project using imx6 with yocto version Fido. I have a display working on FULL HD resolution. I am using a Landscape display but the qt application is in portrait therefore I have to rotate the app 90 degrees to make it portrait. I was using xcb plugin to run my application window in touchscreen. But the performance was not well and the took too much CPU. Therefore I switched to eglfs by following the steps mentioned in here. Now when I run the application window, I get the message

"QEglFSImx6Hooks will set environment variable FB_MULTI_BUFFER=2 to enable double
buffering and vsync.
If this is not desired, you can override this via: export QT_EGLFS_IMX6_NO_FB_M
ULTI_BUFFER=1
Unable to query physical screen size, defaulting to 100 dpi.
To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (i
n millimeters) " .

and only a portion of the application window can be seen on screen.

 

I tried setting QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT, but it is only changing the font size and icon size in the application window (but i need the full application to fit in touchscreen).

Also i cannot rotate the screen and set the resolution in pixal, when I tried setting QT_QPA_EGLFS_ROTATION, QT_QPA_EGLFS_WIDTH and QT_QPA_EGLFS_HEIGHT there was no change in application window. 

 

I am new to Qt  and I have no idea how to solve this. Any help would be appreciated.

Thank you.

Outcomes