AnsweredAssumed Answered

SD card not detected on the LS1043ARDB Rev1.1

Question asked by Zaid Albassam on Feb 23, 2018
Latest reply on Mar 15, 2018 by Zaid Albassam

Hi,

 

I received a new LS1043ARDB Rev1.1 and I see that the u-boot (and the kernel) is not detecting the sd card, see below. Is there a difference between rev1.0 v rev 1.1 regarding the sdhc? or maybe in the wiring? Thanks.

 

<p>

U-Boot 2017.07-g503eff0 (Sep 26 2017 - 15:00:50 +0800)

SoC: LS1043AE Rev1.1 (0x87920011)
Clock Configuration:
CPU0(A53):1600 MHz CPU1(A53):1600 MHz CPU2(A53):1600 MHz
CPU3(A53):1600 MHz
Bus: 400 MHz DDR: 1600 MT/s FMAN: 500 MHz
Reset Configuration Word (RCW):
00000000: 08100010 0a000000 00000000 00000000
00000010: 14550002 80004012 e0025000 c1002000
00000020: 00000000 00000000 00000000 00038800
00000030: 00000000 00001101 00000096 00000001
Model: LS1043A RDB Board
Board: LS1043ARDB, boot from vBank 0
CPLD: V2.0
PCBA: V5.0
SERDES Reference Clocks:
SD1_CLK1 = 156.25MHZ, SD1_CLK2 = 100.00MHZ
I2C: ready
DRAM: Initializing DDR....
Detected UDIMM Fixed DDR on board
1.9 GiB (DDR4, 32-bit, CL=11, ECC off)
Using SERDES1 Protocol: 5205 (0x1455)
SEC0: RNG instantiated
PPA Firmware: Version LSDK-17.09
Firmware 'Microcode version 0.0.1 for LS1021a r1.0' for 1021 V1.0
QE: uploading microcode 'Microcode for LS1021a r1.0' version 0.0.1
Flash: 128 MiB
NAND: 512 MiB
MMC: FSL_SDHC: 0
EEPROM: NXID v1
In: serial
Out: serial
Err: serial
Net: Fman1: Uploading microcode version 108.4.9
PCIe0: pcie@3400000 disabled
PCIe1: pcie@3500000 Root Complex: no link
PCIe2: pcie@3600000 Root Complex: no link
FM1@DTSEC1, FM1@DTSEC2, FM1@DTSEC3 [PRIME], FM1@DTSEC4, FM1@DTSEC5, FM1@DTSEC6, FM1@TGEC1
Hit any key to stop autoboot: 0
=>
=> mmc list
FSL_SDHC: 0
=> mmc rescan
MMC: no card present
mmc_init: -123, time 1001
=> mmcinfo
MMC: no card present
mmc_init: -123, time 1000
=>

</p>

Outcomes