AnsweredAssumed Answered

S32K v3.0.0 and R2017b license error solved

Question asked by Leon Thürnau on Feb 16, 2018
Latest reply on Feb 19, 2018 by dumitru-daniel.popa

Hello dumitru-daniel.popa

 

first time I have a tipp for you !

 

Like discussed here https://community.nxp.com/thread/467938#comment-980540 I wanted to use S32Kv3.0.0 toolbox with R2017b and got this license error:

 

 

I made all the steps recommended and completely new downloaded and installed the toolbox.

 

- I generated a new license file and saved it with the file extension .lic to the installation folder

RESET the MATLAB default paths to DEFAULT using the Set Path menu to remove all previous toolboxes

- run the mbd_s32K_path.m to add the S32K1xx into MATLAB

added the lic folder manually to the Matlab paths

 

 

In opposite to v2.0 (which does not work with R2017b) I was not able to change the path during installation of v3.0.

So now I simply copied the installed content of v3.0 toolbox from the automatic generated path to a different folder and that solved the problem after simply running the mbd_s32K_path.m again.

Maybe the standard installation path was too long or the space in my username leads to some problems so the lic file couldn't be found. 

Anyway...

 

Best regards

 

Leon

 

 

Outcomes