AnsweredAssumed Answered

Problem using paged memory

Question asked by Daniel Milutinovic on Feb 16, 2018
Latest reply on Feb 22, 2018 by Daniel Milutinovic

Hi,

 

I have been using CodeWarrior IDE v5.9.0 build 5294 (Development Studio for S12(X) v5.2 build 151201) on a Windows7 machine for about a year to upload assembly code to the DEVKIT S12G128 board without any problems. Last week I started using paged memory as my project has exceeded 64K. I now receive an error message when trying to upload code to the DEVKIT S12G128. 

 

I can't even upload the following simple program:

Pressing "Make" assembles this program without a problem, and I can view the main.asm.o.lst file but when I connect the DEVKIT S12G128 and press "Debug" I receive the following error messages:

 

 

I tried opening a new project and also tried uploading from another computer with the same version of CodeWarrior, but the same error messages appear. 

As mentioned above, programs that do not have paged memory upload without any problems. 

Please help!

Outcomes