AnsweredAssumed Answered

yocto mono layer

Question asked by tüskemáté on Feb 15, 2018
Latest reply on Feb 20, 2018 by gusarambula

   Hi,

 

I'm working on a system where i can run c# applications in raspberry pi. I'm just switched to yocto rocko, and somehow now I always fail on the do_package_qa task. This is my error message:

 

ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/3.5-api/Microsoft.Build.Engine.dll contained in package mono-libs-3.5 requires mono(System.Xml), but no providers found in RDEPENDS_mono-libs-3.5? [file-rdeps] 
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/3.5-api/Microsoft.Build.Utilities.v3.5.dll contained in package mono-libs-3.5 requires mono(System), but no providers found in RDEPENDS_mono-libs-3.5? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/3.5-api/Microsoft.Build.Engine.dll contained in package mono-libs-3.5 requires mono(mscorlib), but no providers found in RDEPENDS_mono-libs-3.5? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll contained in package mono-configuration-crypto requires mono(mscorlib), but no providers found in RDEPENDS_mono-configuration-crypto? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll contained in package mono-configuration-crypto requires mono(System.Xml), but no providers found in RDEPENDS_mono-configuration-crypto? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll contained in package mono-configuration-crypto requires mono(System), but no providers found in RDEPENDS_mono-configuration-crypto? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll contained in package mono-configuration-crypto requires mono(System.Configuration), but no providers found in RDEPENDS_mono-configuration-crypto? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll contained in package mono-configuration-crypto requires mono(Mono.Security), but no providers found in RDEPENDS_mono-configuration-crypto? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/4.6-api/Mono.Debugger.Soft.dll contained in package mono-api-4.6 requires mono(Mono.Cecil), but no providers found in RDEPENDS_mono-api-4.6? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/4.6.2-api/Mono.Debugger.Soft.dll contained in package mono-api-4.6.2 requires mono(Mono.Cecil), but no providers found in RDEPENDS_mono-api-4.6.2? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/4.7-api/Mono.Debugger.Soft.dll contained in package mono-api-4.7 requires mono(Mono.Cecil), but no providers found in RDEPENDS_mono-api-4.7? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/xbuild/Microsoft/NuGet/Microsoft.NuGet.Build.Tasks.dll contained in package mono-xbuild requires mono(mscorlib), but no providers found in RDEPENDS_mono-xbuild? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/4.6.1-api/Mono.Debugger.Soft.dll contained in package mono-api-4.6.1 requires mono(Mono.Cecil), but no providers found in RDEPENDS_mono-api-4.6.1? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/gac/Mono.Messaging.RabbitMQ/4.0.0.0__0738eb9f132ed756/Mono.Messaging.RabbitMQ.dll contained in package mono-gac requires mono(mscorlib), but no providers found in RDEPENDS_mono-gac? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA Issue: /usr/lib/mono/4.5/Microsoft.CodeAnalysis.Scripting.dll contained in package mono-libs-4.5 requires mono(System.Runtime.Loader), but no providers found in RDEPENDS_mono-libs-4.5? [file-rdeps]
ERROR: mono-5.4.1.6-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
ERROR: mono-5.4.1.6-r0 do_package_qa: Function failed: do_package_qa

 

My mono version is 5.8.0.108 from http://download.mono-project.com/repo/ubuntu  and I'm using xenial ubuntu. The local.conf is now the sample from here:https://git.yoctoproject.org/cgit.cgi/poky/plain/meta-poky/conf/local.conf.sample . 

Any suggestion?

 

regards

Matthew

Outcomes