AnsweredAssumed Answered

Problem with PCI host driver in IMX6 kernel 3.14.28

Question asked by Jemish Patel on Feb 12, 2018
Latest reply on Feb 28, 2018 by Jemish Patel

Hi All,

 

  • We are using IMX6  (IMX6 part number: MCIMX6Q6AVT10AD) based board in our product.
  • In our board we have connected Marvell Azurewave module (88W8897) on PCIE bus via M.2 KEY.E connector.
  • The issue is that we just enable PCIE related config in our kernel and in kernel log I see that host probe failed with below messages:

imx6q-pcie 1ffc000.pcie: phy link never came up
imx6q-pcie 1ffc000.pcie: DEBUG_R0: 0x00b5bc43, DEBUG_R1: 0x08000000
imx6q-pcie 1ffc000.pcie: Failed to bring link up!
imx6q-pcie 1ffc000.pcie: failed to initialize host
imx6q-pcie: probe of 1ffc000.pcie failed with error -22

  • I have go through suggestions provided by NXP community. To disable "CONFIG_PCI_MSI" from kernel config.
  • Also removed below two lines from device tree:

        intc: interrupt-controller@00a01000 {
                compatible = "arm,cortex-a9-gic";
                #interrupt-cells = <3>;
-               #address-cells = <1>;
-               #size-cells = <1>;
                interrupt-controller;
                reg = <0x00a01000 0x1000>,
                      <0x00a00100 0x100>;

Still no success.

Are there any suggestions from Hardware or Software perspective? I am attaching my kernel config and device tree for reference. We have taken wandboard as reference. 

Please let me know if anything needed from my side.

 

Thanks,

Jemish

Outcomes