AnsweredAssumed Answered

Error : Unable to mount root fs via NFS

Question asked by Vipin Rai P on Feb 9, 2018
Latest reply on Feb 20, 2018 by Pavel Chubakov

Hi ,

I am getting error while trying to mount rootfs using nfs on my t2080rdb , the details of the boot log is added below :

 

Board : T2080rdb

 

u-boot variables :

bootargs = root=/dev/nfs console=$consoledev,$baudrate nfsroot=$nfsroot ip=$ip

ip = 192.168.15.3:192.168.15.2:192.168.15.1:255.255.255.0:t2080rdb:eth4:off

nfsroot = 192.168.15.2:/nfs/

netdev = eth4

 

Boot log :

 

VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6
Please append a correct "root=" boot option; here are the available partitions:
1f00 131072 mtdblock0 (driver?)
1f01 524288 mtdblock1 (driver?)
1f02 65536 mtdblock2 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
CPU: 4 PID: 1 Comm: swapper/0 Not tainted 3.12.37-rt51-QorIQ-SDK-V1.8+gf488de6 #1
Call Trace:
[c0000000f90df8d0] [c000000000008c54] .show_stack+0x7c/0x1cc (unreliable)
[c0000000f90df9a0] [c00000000074493c] .dump_stack+0x8c/0xb8
[c0000000f90dfa20] [c000000000742344] .panic+0xe8/0x24c
[c0000000f90dfab0] [c0000000009fb104] .mount_block_root+0x25c/0x33c
[c0000000f90dfba0] [c0000000009fb498] .mount_root+0x154/0x17c
[c0000000f90dfc50] [c0000000009fb694] .prepare_namespace+0x1d4/0x234
[c0000000f90dfce0] [c0000000009fac68] .kernel_init_freeable+0x22c/0x26c
[c0000000f90dfda0] [c000000000001f60] .kernel_init+0x2c/0x10cc
[c0000000f90dfe30] [c000000000000890] .ret_from_kernel_thread+0x5c/0xcc

 

I tried the following command from uboot :

 

=> nfs 10000 192.168.15.2:/nfs

ERROR : cannot mount

 

I tried by mounting from other linux pc it worked fine.

 

I have attached the boot log , please refer it.

Outcomes