AnsweredAssumed Answered

Programming LPCXpresso54018 board produces "The flash loader program reported an error" in IAR

Question asked by Vivek Srinivasan on Feb 8, 2018
Latest reply on Feb 12, 2018 by Vivek Srinivasan

Hi Guys,

 

I recently had a chance to experiment with the LPCXpresso54018 board. I was just trying out different example codes that came with the SDK "SDK_2.3.0_LPCXpresso54018"(mainly the UART examples) using IAR. It was working fine for a day and then the next day after few download and debugging, suddenly this error popped up and not able to program the board after many retries.

I tried few things to debug this issue:

1. We have another spare LPCXpresso54018 board which produces the same error when trying to program the board at the very first attempt.

2. I tried to program this board on a different PC but the same error shows up.     

3. Tried powering the board directly from the PC instead of a USB hub.   

4. Tried reprogramming the LPC-Link2 to use J-Link instead of CMSIS-DAP using the LPCScrypt installation

5. Tried forcing the board into an ISP boot mode by holding down ISP2 or ISP1 and pressing and releasing the reset button(I'm not sure what is supposed to happen by doing this but did it anyway)

 

 

At this stage, I’m not sure what could be the cause of this error since none of the above steps helped. I have attached the IAR debug log for your reference. I don't think that both the boards are doomed since I was just trying out the example codes from the SDK. Could you please help me identify the cause of this error?

 

Thanks for your help!

 

Cheers,

Vivek

Outcomes