AnsweredAssumed Answered

IMX6DL YOCTO编译QT 5.10 无法运行QT程序

Question asked by SEN DONG on Feb 6, 2018
Latest reply on Feb 7, 2018 by SEN DONG

使用“Freescale_Yocto_Project_User's_Guide_20.pdf”配置YOCTO工程后(linux内核4.1.15,x11),切换了meta-qt5的branch为:master,使用命令“bitbake fsl-image-qt5”编译出的rootfs包含qt5.10。

但是烧到IMX6DL的板子上后,大部分QT自带DEMO运行后就崩溃,少部分DEMO程序可以运行,我自己写的程序运行后有很严重的花屏现象。YOCTO工程只切换了META-QT5的branch,没做其他修改。

有人遇到这种情况吗,如果有请分享一下解决办法,谢谢。

 

另外,如果编译的镜像为fsl-imx-fb的话,程序无法启动,不提示任何错误直接崩溃(Segmentation fault)。

Outcomes