AnsweredAssumed Answered

LPC-Link2 debugger crashes with MIMXRT1052 processor and LCD

Question asked by craigsmith on Jan 29, 2018
Latest reply on Feb 6, 2018 by Artur Petukhov

Hi everyone,

I've been having an issue with using the LPC-Link2 debugger with the MIMXRT1052-EVK evaluation kit and I'd like to know if anyone has seen anything similar?

 

The issue is, when debugging code which displays an image on the LCD, the LPC-Link2 loses debug connection with the dev kit as soon as there an image on the LCD.  Error message is: 

16: Target error from status-poll: Ee(FF). Redlink interface error 255.
Debugging context: evkmimxrt1050_usb_examples_host_hid_mouse_keyboard_freertos Debug

 

My set up is:

  • External DC Power supply (no powering from USB)
  • Rocktech LCD connected (same result with Kyocera 4.3" LCD also).
  • OpenSDA disconnected from processor (J29, J30, J31, J32 jumpers removed)
  • LPC-Link2 debugger connected to JTAG header (J21)

 

Workarounds:

  • If LCD not driven with any image (ie, all black pixels only) there is no problem, can debug any other code fine.
  • No debugging - if I run in standalone mode from XIP Hyperflash there is no problem, code is stable
  • Other debuggers - J-Link and OpenSDA debuggers work fine and debug with the same code

 

Now obviously the workarounds aren't ideal as my application depends on using an LCD, I need to debug my code, OpenSDA is very slow (and I won't be installing in our our product's custom PCB) and J-Link are expensive when having to buy for whole development team!

 

I've tried shielding the LCD FPC and the LPC-Link2 JTAG cable.  This had no effect.  Does anyone else have any suggestions or insight as to what may be occurring?

Outcomes