AnsweredAssumed Answered

HISC interface

Question asked by Alessandro Maggi on Jan 26, 2018
Latest reply on Feb 19, 2018 by Alessandro Maggi

Hello,

I'm working on  a custom board(designed by us) based on IMX6 SoloX. Since I need on more ethernet interface, I  connected via HSIC bus a Microchip's LAN9730 (USB to ethernet) to the USB Controller HOST core.

For some reason I cannot make it work. I've tried both the driver included in linux kernel and the one provided by microchip but none of them works.

I checked the MUX and PAD registers, basically 

 

IOMUXC_SW_MUX_CTL_PAD_USB_H_DATA

IOMUXC_SW_MUX_CTL_PAD_USB_H_STROBE

 

IOMUXC_SW_PAD_CTL_PAD_USB_H_DATA

IOMUXC_SW_PAD_CTL_PAD_USB_H_STROBE

 

I enabled clock in CCGR6, and after this I can access USB registers (the ones at address 0x02184XXX), even if I don't know what to check exaclty because i'm a newbie on USB and HSIC.

The problem is that the function probe of the driver is never called, and I have no idea on how to trigger it (I tried to reset the controller with USB_nCMD with no effects). 

If I check the lines STROBE and DATA with the oscilloscope they are not moving at all.

 

I have no idea on what is wrong and what I could investigate to understand the problem.

 

Any help would be apreciated.

 

 

 

Outcomes