AnsweredAssumed Answered

Cant able to play video via gstreamer using fpsdisplaysink plugin

Question asked by Manoj Sampathkumar on Jan 14, 2018
Latest reply on Jan 16, 2018 by Joan Xie

Hi

 

I am using the yocto Morty release and 4.9 kernel in that I am trying to play a video using GStreamer along with fpsdisplaysink plugin. But I am unable to play the video . 

 

 

 # DEBUG=3 gst-launch-1.0 filesrc location=input.mp4 ! decodebin ! fpsdisplaysink

 

Setting pipeline to PAUSED ...
display(/dev/fb0) resolution is (1920x1080).
====== OVERLAYSINK:mxc_v4l2_output v4l2_out: Bypass IC.
4.2.1 build on Dec 29 2017 13:15mxc_v4l2_output v4l2_out: Bypass IC.
:48. ======
display(/dev/fb0) resolution is (1920x1080).
display(/dev/fb0) resolution is (1920x1080).
alloc_contig_range: [76000, 763f5) PFNs busy
Pipeline is PREROLLING ...

====== AIUR: 4.2.1 build on Dec 29 2017 13:15:33. ======
Core: MPEG4PARSER_06.09.36 build on Aug 23 2016 05:18:47
file: /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.2
------------------------
Track 00 [video_0] Enabled
Duration: 0:00:52.208000000
Language: und
Mime:
video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)avc, width=(int)1920, height=(int)1080, framerate=(fra
------------------------
------------------------
Track 01 [audio_0] Enabled
Duration: 0:00:51.946000000
Language: und
Mime:
audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)48000, bitrate=(int)0, stream-format=(string)raw, codec_data=(buffer)1190
------------------------

====== BEEP: 4.2.1 build on Dec 29 2017 13:15:37. =alloc_contig_range: [76c00, 770ff) PFNs busy
=====
Core: AAC decoder Wrapperalloc_contig_range: [76c00, 771ff) PFNs busy
build on May 30 2016 12:33:44
alloc_contig_range: [76c00, 772ff) PFNs busy
file: /usr/lib/imx-mm/audio-codealloc_contig_range: [76c00, 773ff) PFNs busy
c/wrap/lib_aacd_wrap_arm12_elinuxalloc_contig_range: [77000, 774ff) PFNs busy
.so.3
CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.09.00_CORTEX-A8 build on Jul 13 2016 18:15:25.
[INFO] bitstreamMode 1, chromaInterleave 0, mapType 0, tiled2alloc_contig_range: [76000, 7637d) PFNs busy
LinearEnable 0
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
alloc_contig_range: [76000, 7637d) PFNs busy
gst-launch-1.0: ../imxvpuapi/imxvpuapi_vpulib.c:2368: imx_vpu_dec_mark_framebuffer_as_displayed: Assertion `framebuffer != NULL' failed.
Aborted.

 

Is there any patch for this or how to solve this issue.

 

Hoping for better guidance .

 

 

Best regards

Manoj

 

 

 

Outcomes