AnsweredAssumed Answered

MCUXpresso not obeying Task Tags settings

Question asked by David Rodgers on Jan 5, 2018

I'm having trouble customizing my "Tasks" view in MCUXpresso 10.1.0.  If I open Window / View / General / Tasks, I can see a list of TODOs and FIXMEs that are present in my project (marked simply by the existence of the words "TODO" or "FIXME" in a comment).  Unfortunately, the list of tasks is utterly polluted by 100+ TODOs present just in the CMSIS headers and in the lwIP code.  And the Tasks window limits you to 100 visible entries (at the top it currently shows "Filter matched 100 of 171 items").

 

So, what I want to do is use my own custom tags ("LSTODO", "LSFIXME", etc) and filter only on those, ignoring all the tags in existing library code, so that I can see exactly what tasks remain in my own code.  Now, I can either go into Window / Preferences / General / Editors / Structured Text Editors / Task Tags, or Project Properties / Task Tags, and pull up the workspace settings or project-specific settings respectively.  (Conveniently, each has a link to the other near the top.)  I figure that existing FIXMEs are important, but I want to ignore all the others.  So I go into both the workspace and project-specific task tag settings and delete "TODO" and "XXX" as keywords, leaving "FIXME" as the only defined task tag keyword.

 

Here's the problem... I'm still seeing all of the existing TODOs in my Tasks window.  Why?  I've edited both sets of task tag settings, and "FIXME" is the only defined tag.  Why are comments marked "TODO" still showing up in the Tasks window?  When I right-click the project and rebuild the index, I can see that the Tasks are briefly flushed.  But as the indexing continues, all the TODO tasks reappear, along with FIXME and XXX tasks.

 

What's going on?  Why is MCUXpresso/Eclipse seemingly ignoring my Task Tags settings?

Outcomes