AnsweredAssumed Answered

Disable display manager on hdmi output

Question asked by ranshalit on Dec 14, 2017
Latest reply on Dec 19, 2017 by ranshalit

Hello,

 

I am trying to disable X11.

I need to use the hdmi output for other purpose.

 

 

I first disabled desktop environment with:

systemctl set-default multi-user.target

Then I stopped having the gnome , but I get xterm terminal in hdmi.

trying to kill the process did not help, because it is always creates a new xterm process.

I also changed bootargs and removed the console=115200,ttymxc0 , yet I still get the terminal and I keep getting the process

root@imx6qsabresd:/etc# ps aux | grep xter
root       395  0.0  0.0   2200  1404 ttymxc0  Ss+  13:41   0:00 /sbin/agetty -8 -L ttymxc0 115200 xterm

 

Not sure which service is responsible for that.

Is there a way to disable xterm ?


I even created fb distro, but even then xterm is still showing in hdmi output !!! Is there a way to get rid of it ?

 

 

Thank you

Ran

Outcomes